Builds the designated geometrical objects from the stored face sets.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- target
- Type: Autodesk.Revit.DB TessellatedShapeBuilderTarget
What kind of geometrical object(s) should be built.
- fallback
- Type: Autodesk.Revit.DB TessellatedShapeBuilderFallback
What should be done if a GeometryObject described by the 'target' parameter cannot be built using all data from all stored face sets.
- graphicsStyleId
- Type: Autodesk.Revit.DB ElementId
The id of the graphics style for the created geometrical objects. Pass InvalidElementId to skip assigning a custom graphics style.
Return Value
Returns the geometrical objects which were built and some additional information.Remarks
Currently only "Solid/Abort", "AnyGeometry/Mesh" and "Mesh/Salvage" target/fallback combinations are supported. Note that this function does not erase the face sets stored in the builder. If the same builder is used to construct geometrical objects for different collections of face sets, ( Clear ) should be called while switching from one collection to another.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This combination of fallback and target parameters cannot be used as a valid combination of inputs. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | Throws if data in the stored face sets are so inconsistent, that they cannot be used in their entirety. |