IModelExportContext Interface


An interface that is used in custom export to export 3D views of a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public interface IModelExportContext : IExportContext
Visual Basic
Public Interface IModelExportContext _
	Inherits IExportContext
Visual C++
public interface class IModelExportContext : IExportContext

Remarks

An instance of a class that implements this interface is passed in as a parameter of the [!:Autodesk::Revit::DB::CustomExporter] constructor. The interface methods are then called at times of drawing entities that are currently visible in the view being exported.

With this type of export context used to perform a custom export, Revit will traverse the model and output the model's geometry as if in the process of regular displaying or exporting a 3D View. It means that any geometry which is visible in an open view (taking any current visibility setting applicable to the view) will be processed and output.

See Also