Parses a formatted string into a number with units if possible.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- units
- Type: Autodesk.Revit.DB Units
The units formatting settings, typically obtained from Document.GetUnits() .
- unitType
- Type: Autodesk.Revit.DB UnitType
The target unit type for the value.
- stringToParse
- Type: System String
The string to parse.
- valueParsingOptions
- Type: Autodesk.Revit.DB ValueParsingOptions
Additional parsing options.
- value
- Type: System Double %
The parsed value, in Revit's internal units. Ignore this value if the function returns false.
- message
- Type: System String %
A localized message that, if the parsing fails, explains the reason for failure.
Return Value
True if the string can be parsed, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | unitType is an invalid unit type. See UnitUtils.IsValidUnitType() and UnitUtils.GetValidUnitTypes(). -or- The display unit in the FormatOptions in valueParsingOptions is not a valid display unit for unitType. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType) and UnitUtils.GetValidDisplayUnits(UnitType). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |