Creates a new curve that is an offset of the existing curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- offsetDist
- Type: System Double
The signed distance of the offset.
- normal
- Type: Autodesk.Revit.DB XYZ
The normal of the plane defining the offset direction.
Return Value
The new curve.Remarks
The offset curve is theoretically defined by translating every point of the original curve by the vector offsetDist * (curveTan x normal) of the curve by the signed offset distance offsetDist, within the plane of the curve. The "right" side of the curve at a given point on the curve is defined with reference to normal being thought of as the upward direction and curveTan being thought of as the forward direction, as if you are walking along the curve. It follows that if offsetDist is positive, points will be offset to the right of the curve, whereas if offsetDist is negative, points will be offset to the left of the curve.
Note that for elliptical fragments and NurbSpline curves, the offset will be created as a HermiteSpline. This method does not support offset of full cyclic ellipses.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Cannot create the offset of the curve. |