Enum listing the possible results after loading a linked model.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Uninitialized | Revit has not tried to load the link, possibly because it is a nested link and its parent failed to load. |
LinkLoaded | The linked model loaded correctly. |
LinkNotFound | The linked model could not be found. |
LinkNotOpenable | An error occurred trying to read the linked model. |
LinkOpenAsHost | The linked model is already opened directly in Revit. |
SameModelAsHost | The linked model has the same path as the currently active document. |
SameCentralModelAsHost | Either the linked model and its host document are both locals of the same central model, or one is a local and the other is its central. |
LinkNotLoadedOtherError | An unknown error occurred. |
LinkMayBeUpgraded | Point cloud link loaded correctly but is obcolete and may be upgraded. |
ExternalServerMissing | The external add-in required to load this link model could not be found. |
LinkExists | The linked model which Revit is trying to load is using a path that is already being used by a different RvtLinkSymbol. |
Remarks
For all values except LinkLoadResultType.LinkLoaded, the linked model is not loaded and no new link is created (if Revit was trying to create a link).