Creates an object to specify user preferences in parsing of geometry.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
Examples

Autodesk.Revit.DB.Options geomOption = application.Create.NewGeometryOptions();
if (null != geomOption)
{
geomOption.ComputeReferences = true;
geomOption.DetailLevel = Autodesk.Revit.DB.ViewDetailLevel.Fine;
// Either the DetailLevel or the View can be set, but not both
//geomOption.View = commandData.Application.Application.ActiveDocument.ActiveView;
TaskDialog.Show("Revit", "Geometry Option created successfully.");
}

Dim geomOption As Autodesk.Revit.DB.Options = application.Create.NewGeometryOptions()
If geomOption IsNot Nothing Then
geomOption.ComputeReferences = True
geomOption.DetailLevel = Autodesk.Revit.DB.ViewDetailLevel.Fine
' Either the DetailLevel or the View can be set, but not both
'geomOption.View = commandData.Application.Application.ActiveDocument.ActiveView;
TaskDialog.Show("Revit", "Geometry Option created successfully.")
End If