SetPointCloudOverrideSettings Method (ElementId, PointCloudOverrideSettings)


Assigns override settings to the whole PointCloudInstance element.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public void SetPointCloudOverrideSettings(
	ElementId elementId,
	PointCloudOverrideSettings newSettings
)
Visual Basic
Public Sub SetPointCloudOverrideSettings ( _
	elementId As ElementId, _
	newSettings As PointCloudOverrideSettings _
)
Visual C++
public:
void SetPointCloudOverrideSettings(
	ElementId^ elementId, 
	PointCloudOverrideSettings^ newSettings
)

Parameters

elementId
Type: Autodesk.Revit.DB ElementId
Id of the element to be overridden.
newSettings
Type: Autodesk.Revit.DB.PointClouds PointCloudOverrideSettings
Override settings to be assigned.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also