GetMemberForces Method


Gets the member forces associated with this element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public IList<MemberForces> GetMemberForces()
Visual Basic
Public Function GetMemberForces As IList(Of MemberForces)
Visual C++
public:
IList<MemberForces^>^ GetMemberForces()

Return Value

Returns a collection of Member Forces associated with this element. Empty collection will be returned if element doesn't have any Member Forces. To find out with which end member forces are associated use [!:Autodesk::Revit::DB::Structure::MemberForces::Position] property to obtain a position of Member Forces on element.

Remarks

Using this method require transaction.

See Also