Create Method


Creates a polyline with coordinate points provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public static PolyLine Create(
	IList<XYZ> coordinates
)
Visual Basic
Public Shared Function Create ( _
	coordinates As IList(Of XYZ) _
) As PolyLine
Visual C++
public:
static PolyLine^ Create(
	IList<XYZ^>^ coordinates
)

Parameters

coordinates
Type: System.Collections.Generic IList XYZ

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Thrown when the count of coordinates is less than 2.

See Also