Creates a new SelectionFilterElement in the given document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which to create the SelectionFilterElement.
- name
- Type: System String
The name for the new SelectionFilterElement.
Return Value
The new SelectionFilterElement.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | name is an empty string. -or- The given value for name is already in use as a filter element name. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |