FaceNormal Property


Normal of the planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
public XYZ FaceNormal { get; }
Visual Basic
Public ReadOnly Property FaceNormal As XYZ
	Get
Visual C++
public:
property XYZ^ FaceNormal {
	XYZ^ get ();
}

Remarks

This property is the "face normal" vector, and thus should return a vector consistently pointing out of the solid that this face is a boundary for (if it is a part of a solid).

See Also