CurveElement Class


Represents a curve element in Autodesk Revit. This could be a Model Line,Detail Line, or other specialty curve such as a Room Boundary Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class CurveElement : Element
Visual Basic
Public Class CurveElement _
	Inherits Element
Visual C++
public ref class CurveElement : public Element

Inheritance Hierarchy

See Also