Finds an existing PropertySetLibrary with a given name.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document in which to look for PropertySetLibrary elements with the given name.
- name
- Type: System String
The name to search for.
Return Value
Identifier of the PropertySetLibrary with the given name, or invalidElementId if no library with that name exists.Remarks
The search is case-insensitive.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |