Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- background
- Type: Autodesk.Revit.DB ViewDisplayBackground
Background to set. See 'ViewDisplayBackground' class and its 'create' methods.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The background object is invalid, or view has 'Rendering' style. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | This view does not contain display-related properties. |