Creates a new detail section assembly view for the assembly instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to which the view will be added.
- assemblyInstanceId
- Type: Autodesk.Revit.DB ElementId
Id of the assembly instance that owns the new view.
- direction
- Type: Autodesk.Revit.DB AssemblyDetailViewOrientation
The direction for the new view.
Return Value
A new detail section assembly view.Remarks
The detail section will cut through the center of the assembly instance's outline. The document must be regenerated before using the detail section.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | assemblyInstanceId is not an AssemblyInstance. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |