Sets the status of given specific angle.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- angle
- Type: System Double
The specific angle (in degree) that must be 60, 45, 30, 22.5 or 11.25 degrees.
- bStatus
- Type: System Boolean
Status, true - using the given angle during the pipe layout.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The given value for angle must be 90, 60, 45, 30, 22.5 or 11.25 degrees. |
Autodesk.Revit.Exceptions InvalidOperationException | Can not set an angle status for an invalid angle. |