Exports the document in the format of Civil Engineering design applications.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folder
- Type: System String
Output folder, into which file will be exported. The folder must exist.
- name
- Type: System String
The name for the exported civil file. If a null reference ( Nothing in Visual Basic) or empty, automatic naming will be used."
- view
- Type: Autodesk.Revit.DB View3D
3D View to be exported.
- grossAreaPlan
- Type: Autodesk.Revit.DB ViewPlan
All the areas on the view plan will be exported, it must be 'Gross Building' area plan. It must not be a null reference ( Nothing in Visual Basic) . To check whether its area scheme is Gross Building, use IsGrossBuildingArea property of AreaScheme .
- options
- Type: Autodesk.Revit.DB BuildingSiteExportOptions
Various options applicable to the format of Civil Engineering design applications. If a null reference ( Nothing in Visual Basic) , all options will be set to their respective default values.
Return Value
True if successful, otherwise False.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input view or grossAreaPlan is a null reference ( Nothing in Visual Basic) |
Autodesk.Revit.Exceptions ArgumentException | Thrown when folder is null or empty.Thrown when name is not valid.Thrown when grossAreaPlan is not a valid element.Thrown when grossAreaPlan is not a Gross Building Area Plan. |
Autodesk.Revit.Exceptions DirectoryNotFoundException | Thrown when the folder does not exist |