Vector Property


Defining vectors of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2016.  Use the XVector and YVector properties instead.")]
public XYZ this[
	int index
] { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2016.  Use the XVector and YVector properties instead.")> _
Public ReadOnly Property Vector ( _
	index As Integer _
) As XYZ
	Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2016.  Use the XVector and YVector properties instead.")]
public:
property XYZ^ Vector[int index] {
	XYZ^ get (int index);
}

Parameters

index
Type: System Int32

See Also