Determines whether an element can be repeated using the RepeatElements method.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2015 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADoc
- Type: Autodesk.Revit.DB Document
The document containing the element.
- elementId
- Type: Autodesk.Revit.DB ElementId
The element to be tested.
Return Value
True if the element can be repeated.Remarks
The element must be an adaptive family instance and have no shape handles. At least one placement point must be hosted on a 1D or 2D repeating reference. All other placement points can be hosted on a 0D, 1D or 2D repeating reference, or must be unhosted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |