GetFoundationType Method


Gets an object that represents the type of the foundation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public WallFoundationType GetFoundationType()
Visual Basic
Public Function GetFoundationType As WallFoundationType
Visual C++
public:
WallFoundationType^ GetFoundationType()

Remarks

The Wall Foundation type can be used to access the multi layered structure of a foundation.

See Also