Sets the analytical model projection to a preset value.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure AnalyticalElementSelector
End of the analytical model.
- projectionY
- Type: Autodesk.Revit.DB.Structure StickElementProjectionY
Preset value for Analytical Model Stick projection Y.
- projectionZ
- Type: Autodesk.Revit.DB.Structure StickElementProjectionZ
Preset value for Analytical Model Stick projection Z.
Remarks
This should be used if setting the analytical model projection to something other than a Plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |