Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- other
- Type: Autodesk.Revit.DB FilteredElementCollector
The other collector
Return Value
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.Remarks
The result will be the same as using a LogicalOrFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter. |