GetStructuralSection Method


Gets the structural section from element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public StructuralSection GetStructuralSection()
Visual Basic
Public Function GetStructuralSection As StructuralSection
Visual C++
public:
StructuralSection^ GetStructuralSection()

Return Value

The structural section. a null reference ( Nothing in Visual Basic) if the family symbol does not contain a structural section.

Remarks

Only beams, braces and structural columns can have a structural section. To check if the element can have structural section use the [!:Family.HasStructuralSection()] method.

See Also