Reloads the image from its origin file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
If reload fails (because the image file doesn't exist or cannot be read), the currently loaded image will remain unchanged. Please note that only images with non-empty path could be reloaded.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions FileNotFoundException | The associated image file of the ImageType doesn't exist. |
Autodesk.Revit.Exceptions InvalidOperationException | This image is not loaded from a file. |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document containing this ImageType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this ImageType is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document containing this ImageType has no open transaction. |