Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which the assembly instances live.
- sourceAssemblyInstanceId
- Type: Autodesk.Revit.DB ElementId
Id of the assembly instance that currently owns the assembly views.
- targetAssemblyInstanceId
- Type: Autodesk.Revit.DB ElementId
Id of the assembly instance which will become the new owner of the assembly views.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | sourceAssemblyInstanceId is not an AssemblyInstance with assembly views. -or- targetAssemblyInstanceId is not an AssemblyInstance. -or- sourceAssemblyInstanceId and targetAssemblyInstanceId are not AssemblyInstances from the same assembly type. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |