GetCallingDocumentModelPath Method


Returns a copy of the ModelPath of the document that is requesting the external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public ModelPath GetCallingDocumentModelPath()
Visual Basic
Public Function GetCallingDocumentModelPath As ModelPath
Visual C++
public:
ModelPath^ GetCallingDocumentModelPath()

Return Value

A copy of the ModelPath of the document that is requesting the external resource.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException The document requesting the external resource does not have a ModelPath, either because it is detached, or because it has not been saved to disk yet.

See Also