Adds a resolution for the failure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- type
- Type: Autodesk.Revit.DB FailureResolutionType
The type of the resolution.
- resolution
- Type: Autodesk.Revit.DB FailureResolution
The resolution.
Return Value
The FailureMessage.Remarks
Each pair of FailureResolutionType and FailureResolution must have been defined in FailureDefinition, and could only be added once.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | type is not a valid resolution type for this FailureMessage. -or- resolution of type is not valid for this FailureMessage. -or- This FailureMessage already contains a resolution of type type. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | This FailureMessage is already posted to a document |