Modifies the input Solid preserving only the volume on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- solid
- Type: Autodesk.Revit.DB Solid
The input Solid to be cut. This object cannot be obtained directly from a Revit element. This means that IsElementGeometry cannot be true.
- plane
- Type: Autodesk.Revit.DB Plane
The cut plane. The space on the positive side of the normal of the plane will be intersected with the input Solid.
Remarks
This operation modifies the original input Geometry objects.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when the original solid object is the geometry of the Revit model. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |