Specifies the value of the tread width excluding the width of independent side supports.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
The actual width of the stairs run, 0.0 if the run is a sketched run.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | When setting this property: The given value for runWidth must be greater than 0 and no more than 30000 feet. -or- When setting this property: The runWidth is too small or too large to be used as actual run width, probably it doesn't satisfy the layout generation restriction of the stairs run. |
Autodesk.Revit.Exceptions InvalidOperationException | When setting this property: The stairs run is sketched so the data being set is not applicable. |