Adds a property set from the document to this library using an alternate name.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- propertySetId
- Type: Autodesk.Revit.DB ElementId
Identifier of the property set to add.
- name
- Type: System String
The alternate name to use for the property set in the library.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given ElementId does not refer to a PropertySetElement -or- The library already contains a property set with the given name. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ObjectAccessException | The property set library is read-only. |