Converts a value from one display unit to another, such as square feet to square meters.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- value
- Type: System Double
The value to convert.
- currentDisplayUnit
- Type: Autodesk.Revit.DB DisplayUnitType
The current display unit.
- desiredDisplayUnit
- Type: Autodesk.Revit.DB DisplayUnitType
The desired display unit.
Return Value
The converted value.Examples

void SetTopOffset(Wall wall, double dOffsetInches)
{
// convert user-defined offset value to feet from inches prior to setting
double dOffsetFeet = UnitUtils.Convert(dOffsetInches,
DisplayUnitType.DUT_DECIMAL_INCHES,
DisplayUnitType.DUT_DECIMAL_FEET);
Parameter paramTopOffset = wall.get_Parameter(BuiltInParameter.WALL_TOP_OFFSET);
paramTopOffset.Set(dOffsetFeet);
}

Private Sub SetTopOffset(wall As Wall, dOffsetInches As Double)
' convert user-defined offset value to feet from inches prior to setting
Dim dOffsetFeet As Double = UnitUtils.Convert(dOffsetInches, DisplayUnitType.DUT_DECIMAL_INCHES, DisplayUnitType.DUT_DECIMAL_FEET)
Dim paramTopOffset As Parameter = wall.Parameter(BuiltInParameter.WALL_TOP_OFFSET)
paramTopOffset.[Set](dOffsetFeet)
End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value for value is not finite -or- currentDisplayUnit is an invalid display unit. See UnitUtils.IsValidDisplayUnit(DisplayUnitType) and UnitUtils.GetValidDisplayUnits(). -or- desiredDisplayUnit is an invalid display unit. See UnitUtils.IsValidDisplayUnit(DisplayUnitType) and UnitUtils.GetValidDisplayUnits(). |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | currentDisplayUnit and desiredDisplayUnit have different dimensions. |