ElementIsCurveDrivenFilter Constructor


Constructs a new instance of a filter to match only curve driven elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public ElementIsCurveDrivenFilter()
Visual Basic
Public Sub New
Visual C++
public:
ElementIsCurveDrivenFilter()

Remarks

The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements.

See Also