NewPipingSystem Method


Creates a new MEP piping system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public PipingSystem NewPipingSystem(
	Connector baseEquipmentConnector,
	ConnectorSet connectors,
	PipeSystemType pipingSystemType
)
Visual Basic
Public Function NewPipingSystem ( _
	baseEquipmentConnector As Connector, _
	connectors As ConnectorSet, _
	pipingSystemType As PipeSystemType _
) As PipingSystem
Visual C++
public:
PipingSystem^ NewPipingSystem(
	Connector^ baseEquipmentConnector, 
	ConnectorSet^ connectors, 
	PipeSystemType pipingSystemType
)

Parameters

baseEquipmentConnector
Type: Autodesk.Revit.DB Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be a null reference ( Nothing in Visual Basic) . The baseEquipmentConnector should not be included in the connectors.
connectors
Type: Autodesk.Revit.DB ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
pipingSystemType
Type: Autodesk.Revit.DB.Plumbing PipeSystemType
The System type.

Return Value

If creation was successful then an instance of piping system is returned, otherwise an exception with information will be thrown.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Thrown when calling this function outside of the Autodesk Revit MEP product.
Autodesk.Revit.Exceptions ArgumentNullException Thrown when the connectors parameter value is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions ArgumentOutOfRangeException Thrown when the pipingSystemType parameter value is out of permitted scope.
Autodesk.Revit.Exceptions ArgumentException Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system.
Autodesk.Revit.Exceptions InvalidOperationException Thrown when the piping system creation failed.

See Also