Copies an element and places the copy at a location indicated by a given transformation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document that owns the element.
- elementToCopy
- Type: Autodesk.Revit.DB ElementId
The id of the element to copy.
- translation
- Type: Autodesk.Revit.DB XYZ
The translation vector for the new element.
Return Value
The ids of the newly created copied elements. More than one element may be created due to dependencies.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element elementToCopy does not exist in the document |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | If we are not able to copy the element. |