Set a view-specific shape of the DirectShapeType object to geometry accumulated in this ViewShapeBuilder object. The view type currently set in ViewShapeBuilder is used. Since the accumulated geometry was validated by ViewShapeBuilder already, this skips the second validation in DirectShapeType. This function resets this ViewShapeBuilder object: the geometry is transferred to DirectShapeType, view normal and view type are invalidated.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- directShapeType
- Type: Autodesk.Revit.DB DirectShapeType
The DirectShape object that will have its view-specific shape representation set to a copy of geometry accumulated in this DirectShapeBuilder.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |