Creates a new hosted line load within the project using data at an array of points.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- reference
- Type: Autodesk.Revit.DB Reference
The Geometry reference to Beam's, Brace's, Column's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical lines.
- forces
- Type: System.Collections.Generic IList XYZ
The applied 3d linear forces in the end points.
- moments
- Type: System.Collections.Generic IList XYZ
The applied 3d linear moments in the end points.
- uniform
- Type: System Boolean
Set to True if you wish to create the uniform load.
- projected
- Type: System Boolean
Set to True if you wish to create the projected load.
- isReaction
- Type: System Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
- symbol
- Type: Autodesk.Revit.DB.Structure LineLoadType
The symbol of the LineLoad.
- plane
- Type: Autodesk.Revit.DB SketchPlane
Indicate the work plane of the LineLoad.
Return Value
If successful, NewLineLoad returns an object for the newly created LineLoad. a null reference ( Nothing in Visual Basic) is returned if the operation fails.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | If the product is not Revit Structure. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the line load symbol does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the work plane does not exist in the given document. |