Gets the local coordinate system (LCS) reflects analytical model orientation at the specified parameter value along a curve.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameter
- Type: System Double
The parameter value along a curve that should be in the range [0, 1], where 0 represents start and 1 represents end of the element.
Return Value
Transformation matrix.- x - longitudinal axis,
- y - transversal, section - horizontal, strong axis,
- z - transversal, section - vertical, weak axis,
- origin - base point of LCS.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | Thrown when parameter is not within the range from 0 to 1. |