Checks if given panel configuration is valid for given panel schedule type.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- scheduleType
- Type: Autodesk.Revit.DB.Electrical PanelScheduleType
The panel schedule type.
- configuration
- Type: Autodesk.Revit.DB.Electrical PanelConfiguration
The given configuration to check.
Return Value
True if panel schedule template can have a valid configuration assigned, false otherwise.Remarks
If the panel schedule type is branch panel, the valid panel configurations are: PanelConfiguration::Enum::OneColumn PanelConfiguration::Enum::TwoColumnsCircuitsAcross PanelConfiguration::Enum::TwoColumnsCircuitsDown If the panel schedule type is switchboard or data panel, the valid panel configuration is: PanelConfiguration::Enum::OneColumn
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |