GetThermalProperties Method


Gets the thermal properties for the given FamilySymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public FamilyThermalProperties GetThermalProperties()
Visual Basic
Public Function GetThermalProperties As FamilyThermalProperties
Visual C++
public:
FamilyThermalProperties^ GetThermalProperties()

Return Value

The thermal properties. a null reference ( Nothing in Visual Basic) if the family symbol does not contain thermal properties.

Remarks

Doors, windows, and curtain wall panels will have thermal properties.

See Also