Creates a new area plan ViewPlan.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to which the area plan will be added.
- areaSchemeId
- Type: Autodesk.Revit.DB ElementId
The id of the AreaScheme which will be used by the area plan.
- levelId
- Type: Autodesk.Revit.DB ElementId
The id of the Level to associate with the area plan.
Return Value
The new area plan ViewPlan.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The AreaScheme id is not valid and cannot be used for area plan views. -or- The ElementId levelId does not correspond to a Level. -or- Plan view creation is not allowed in this family. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |