GetCropRegionShape Method


Gets the crop boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2014

Syntax

C#
[ObsoleteAttribute("Obsolete in Revit 2016, use GetCropShape.")]
public CurveLoop GetCropRegionShape()
Visual Basic
<ObsoleteAttribute("Obsolete in Revit 2016, use GetCropShape.")> _
Public Function GetCropRegionShape As CurveLoop
Visual C++
[ObsoleteAttribute(L"Obsolete in Revit 2016, use GetCropShape.")]
public:
CurveLoop^ GetCropRegionShape()

Return Value

The crop boundary.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException The crop of the associated view is not permitted to have a non-rectangular shape.

See Also