Sets the Layout Rule property of rebar set to NumberWithSpacing
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2009
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- numberOfBarPositions
- Type: System Int32
The number of bar positions in rebar set
- spacing
- Type: System Double
The maximum spacing between rebar in rebar set
- barsOnNormalSide
- Type: System Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
- includeFirstBar
- Type: System Boolean
Identifies if the first bar in rebar set is shown
- includeLastBar
- Type: System Boolean
Identifies if the last bar in rebar set is shown
Remarks
When changing the layout rule to NumberWithSpacing, you must also simultaneously set NumberOfBarPositions, Spacing, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | the number of bar positions numberOfBarPositions is less than 1 or more than 1002. -or- The spacing isn't bigger than 0.0. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions InapplicableDataException | This Rebar is an instance of a spiral or multiplanar shape. |