Length Property


Returns the Length value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
	Get
Visual C++
public:
property double Length {
	double get ();
}

Remarks

This property is used to retrieve the Length value of the Electrical System.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Thrown when the length cannot be computed, because it is zero, or because the circuit is not connected to a panel.

See Also