Returns the necessary information to define a NURBS surface for a given Revit HermiteFace or RuledFace.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- face
- Type: Autodesk.Revit.DB Face
The HermiteFace or RuledFace to be converted.
Return Value
A class containing the necessary data to define a NURBS surface.Remarks
This function is intended for export purposes
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This face type is not supported for this function. -or- GetNurbsSurfaceDataForFace only supports Hermite surfaces. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | Couldn't get NURBS data from face. |