SetFoundationType Method


Sets an object that represents the type of the foundation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2016

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2017. Use ChangeTypeId() instead.")]
public void SetFoundationType(
	WallFoundationType type
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2017. Use ChangeTypeId() instead.")> _
Public Sub SetFoundationType ( _
	type As WallFoundationType _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2017. Use ChangeTypeId() instead.")]
public:
void SetFoundationType(
	WallFoundationType^ type
)

Remarks

The Wall Foundation type can be used to access the multi layered structure of a foundation.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also