FamilySymbolFilter Class


A filter used to find all family symbols of the given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public class FamilySymbolFilter : ElementQuickFilter
Visual Basic
Public Class FamilySymbolFilter _
	Inherits ElementQuickFilter
Visual C++
public ref class FamilySymbolFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Note that it may be faster to get a list of symbol ids from GetFamilySymbolIds rather than to iterate all of the contents of a document with this filter applied.

Inheritance Hierarchy

See Also