Moves a point in a TopographySurface to a new designated location.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- movedPoint
- Type: Autodesk.Revit.DB XYZ
The point to be moved.
- targetPoint
- Type: Autodesk.Revit.DB XYZ
The new designated location of this point will move to.
Remarks
If targetPt exists, the movedPt will be deleted. That means if movedPoint is moved to become a duplicate of an existing point, movedPoint will be deleted instead becuase both points cannot exist at the same location. This applies to a TopographySurface element (not a SiteSubRegion or a topography surface associated with a BuildingPad), which shoule be in an active TopographyEditScope.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input point does not exist in the current topography surface. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | This element is not a TopographySurface. -or- The TopographySurface element is not in an active TopographyEditScope. Modification cannot be made on this TopographySurface. |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document containing this TopographySurface is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this TopographySurface is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document containing this TopographySurface has no open transaction. |