Current Property


Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)

Syntax

C#
public virtual MEPSize Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As MEPSize
	Get
Visual C++
public:
virtual property MEPSize^ Current {
	MEPSize^ get ();
}

Implements

IEnumerator T Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException There is no current item in the iterator.

See Also