GetTypeCatalogString Method (UnitType)


Gets the string used in type catalogs to identify a given unit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public static string GetTypeCatalogString(
	UnitType unitType
)
Visual Basic
Public Shared Function GetTypeCatalogString ( _
	unitType As UnitType _
) As String
Visual C++
public:
static String^ GetTypeCatalogString(
	UnitType unitType
)

Parameters

unitType
Type: Autodesk.Revit.DB UnitType
The unit type.

Return Value

The type catalog string, or an empty string if the unit type cannot be used in type catalogs.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also