Creates a new LoadCase.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The Document to which new load case element will be added.
- name
- Type: System String
The name of the load case.
- natureId
- Type: Autodesk.Revit.DB ElementId
The load nature ID.
- loadCaseCategory
- Type: Autodesk.Revit.DB.Structure LoadCaseCategory
The predefined load case category.
Return Value
The newly created load case element if successful, a null reference ( Nothing in Visual Basic) otherwise.Remarks
This method is designed to create LoadCase that is associated with one of the predefined category.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given name is not unique. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |